在 PythonAnywhere 部署 Watchlist,使用 Pipenv 安装依赖时提示 Flask-Login 包的 hash 不匹配

flask-login

#7

需要更详细的信息。比如完整的错误信息,部署时选择的 Python 版本,Pipfile.lock 的内容等。如果项目放到了 GitHub 上,可以把链接放上来看看。


#8

决定先不管了,买了你的书flask web开发实战,后续遇到问题我再来提问啦。不过当当的云读书读书体验真的好差还要89块。现在很后悔想买实体书了,想买书的朋友还是买实体书吧,书是真的不错! 希望以后可以出更好的书,我也一定会买。


#9

能不能把《Flask Web 开发实战》 在官网上做成付费教程,然后在每个章节下加一个提问区,这样体验可以有:rofl:


#10

建议不要使用 pipenv
直接用 virtualenv
不然卡得想炸电脑


#11

我也遇到了同样的问题,Pythonanywhere部署不了。执行flask initdb,又显示no commod name “initdb”,试了好多遍都不行。题主现在部署好了吗?


#12

我也是这个问题
image


#13

纯代码或命令行文本建议使用代码块格式化。

插入代码块的方式:除了将所有代码缩进四格,更方便的插入代码块方式是使用三个连续的反引号作为开始和结束标记,比如:

```
def hello():
    return ‘Hello World’
```

会被渲染为:

 def hello():
     return 'Hello World'

具体参考论坛说明


#14

我也是,你解决了吗


#15

你的项目放到 GitHub 上了吗,可以把链接分享出来(或者打包发给我 withlihui@gmail.com)。


#16


谢谢你


#17

我在 PythonAnywhere 测试了你的项目,克隆仓库、安装依赖、激活虚拟环境,最后执行 flask initdb 命令并没有报错。建议检查你的步骤和书里是否有不同,重新试一次。


#18

因为这个主题下混杂了几个不同的部署问题,变得很难处理。后续遇到类似问题的同学请新建主题,不要在这里追加提问。


#19

我在pythonanywhere上删除所有之后,又重新走了一遍,还是有问题。我同事测试了你的项目也是这个问题。
我们安装完pipenv 后,查看版本就出现下面问题了:
03:11 ~/watchlist (master)$ pipenv --version
Error, do this: mount -t proc proc /proc
Error, do this: mount -t proc proc /proc
pipenv, version 2018.11.26

然后再创建虚拟环境,直接卡死了很久才跳出来:


我们猜测,是pipenv 与 pythonanywhere存在兼容或者啥问题。你那边测试没问题是因为你之前已经安装了pipenv。如果你的pipenv是新装的,估计也会出现这个问题。


下午更新
同事帮我找到问题所在了。 pipenv 创建虚拟环境的时候,需要调用 proc这个文件。但是当前环境下没有权限调用这个文件。因为我们安装pipenv的时候是用 --user 的权限,这个–user 权限有所限制。而pythonanywhere又不支持超级用户权限 --sudo。


#20

找到一个我这个问题的解决办法:
1、手动生成 requirements.txt文件。
打开powershell, 进入项目根目录(即输入命令 cd d:\py\watchlist,我的项目都放在py文件夹 下),然后运行 pip freeze > requirements.txt

2、把requirements.txt 文件导入到pythonanywhere的文件夹里面。
进入 pythonanywhere里面的Files 界面,点击进入项目文件夹watchlist,然后点击image ,然后选中requirements.txt 文件上传。

3、再在虚拟环境下安装依赖pip install -r requirements.txt
之前虽然运行pipenv install 时报错,依赖没有安装成功,但是这步成功创建了虚拟环境。
我们继续运行 pipenv shell,虽然还是会报错,但是没关系,还是成功激活了虚拟环境。
于是我们继续运行 pip install -r requirements.txt,这时候就能成功安装了。


#21

proc 那个错误提示可以忽略。你的问题和上面某一条回复相同,是安装 Flask-Login 时包的 hash 值对不上,目前来看是 PythonAnywhere 内部缓存了某一个版本的 Flask-Login 安装包文件。你可以在这条命令后手动执行一行下面的命令解决:

$ pipenv install flask-login --skip-lock

#22

对了,你是怎么安装 Pipenv 的,使用的命令是什么?


#23

是按照书上的:pip3 install --user pipenv


#24

好的,有时间可以试一下上面那条命令能否解决问题。


#25

好的。非常感谢你抽空解决我的问题。我同事说你应该试过了可以:grinning:


#26

刚刚试过了。可以解决!:blush: