Flask 2.0.1、APIFlask 0.6.3、Bootstrap-Flask 1.5.3 版本发布

Flask 在上周五发布了 2.0.1 版本,修复了多个 2.0 版本中的 bug,主要包括:

  • 优化和修复了嵌套蓝本相关实现,比如嵌套蓝本 url_prefix 失效的问题
  • 添加回了 2.0 版本中 send_from_directory 函数意外删掉的 filename 参数
  • 添加回了 2.0 版本意外删掉的 Config.from_json 方法
  • 优化了各种类型标注问题

详情可以参考 changelog。 顺便说一句,前两个 PR(#4037#4019)对应的 bug 分别来自我的博客文章读者和 QQ 群用户的反馈。

可以使用下面的命令更新:

pip install -U flask

同时其他 Pallets 项目亦同步释出主版本后的 bugfix 版本:

另外,包含增加 Flask 2.0 支持的 APIFlask 0.6.2 和 0.6.3 版本也已在月初发布。Bootstrap-Flask 也发布了 1.5.3 版本

1 Like